Skocz do zawartości
jurek

Spotify- problemy ze sterowaniem

Rekomendowane odpowiedzi

Miałam zainstalowane raspotify na moode ale od paru dni nie łączyło się z malinką. Zrobiłam edycje pliku według Twojej instrukcji :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Miałam zainstalowane raspotify na moode ale od paru dni nie łączyło się z malinką. Zrobiłam edycje pliku według Twojej instrukcji :)

 

No można i tak :-)

Ważne, że działa.

 

Pozdrawiam

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Którą metodą ? rozumiem, że tą drugą.

Tak od razu ciężko powiedzieć co jest źle.

Po pierwsze sprawdź, czy podczas edycji czegoś źle nie wpisałeś, czasem jedna literka, wielkość mała duża litera ma znaczenie.

 

Poza tym co masz na myśli pisząc, ze telefon nie widzi? Rozumiem Aplikacja Spotify na telefonie nie widzi dodatkowych urządzeń ?

W końcu Jaki telefon znaczy się android czy windows mobile ?

 

Tomek

 

Po gruntownym usunięciu i ponownej instalacji zadziałało Raspotify - aplikacja na androidowym telefonie znalazła i działa bez zarzutów.

Na początek zainstalowałem Raspotify bez jakichkolwiek zmian w nano więć jest sterowanie ale muzyki jeszcze nie.

 

Potem zmieniłem ustawienia zgodnie z instrukcją (dla Digione wpsując: --device plughw:1,0- tak jest dobrze?)

 

Po zmianach znów telefon nie widzi maliny.

Są dwie możliwości:

1. Źle coś wpisałem- będę próbował szukać błędu

2. Jest jakiś zgrzyt systemowy.

Edytowane przez jurek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Po zmianach znów telefon nie widzi maliny.

Są dwie możliwości:

1. Źle coś wpisałem- będę próbował szukać błędu

2. Jest jakiś zgrzyt systemowy.

 

Zobacz co napisałem w poście #25 może to pomoże.

 

U Ruci dla digione poprawne było:

 

--device plughw:0,0

 

Ale u Ciebie może być inaczej, zobacz co napisałem w poście #25.

 

Poza tym podaj co wyświetli takie polecenie:

 

ps aux |grep ./libre

 

i takie:

 

aplay -l |grep card

 

Tom

Edytowane przez tomekwr123

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

volumio@volumio:~$ aplay -l |grep card

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]

card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

card 1: sndallodigione [snd_allo_digione], device 0: Allo DigiOne HiFi wm8804-spdif-0 []

 

 

 

volumio@volumio:~$ ps aux |grep ./libre

volumio 2158 0.0 0.0 2588 548 pts/0 S+ 13:59 0:00 grep ./libre

Edytowane przez jurek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

-> jurek

 

U ciebie ostatnia linijka powinna tak wyglądać:

 

OPTIONS= "--device plughw:1 --initial-volume 100"

 

poza tym z jakiegoś powodu u Ciebie nie startuje raspotify.

 

U mnie wygląda to tak:

 

volumio@volumio:~$ ps aux |grep ./libre

raspoti+ 870 0.0 0.8 13508 4268 ? Ss 13:48 0:00 /usr/bin/librespot --name Raspotify --backend alsa --bitrate 320 --disable-audio-cache --device plughw:1 --initial-volume 100

volumio 2143 0.0 0.3 2580 1524 pts/0 S+ 14:05 0:00 grep ./libre

 

Napisz jeszcze co daje polecenie:

 

cat /etc/default/raspotify

 

u mnie wygląda to tak:

 

volumio@volumio:~$ cat /etc/default/raspotify

# /etc/default/raspotify -- Arguments for librespot

 

# Device name on Spotify Connect

DEVICE_NAME="Raspotify"

 

# Bitrate, one of 96 (low quality), 160 (default quality), or 320 (high quality)

BITRATE="320"

 

# Additional command line arguments for librespot can be set below.

# See `librespot -h` for more info.

#

# To make your device visible on Spotify Connect across the Internet add your

# username and password which can be set via "Set device password", on your

# account settings, use `--username` and `--password`.

#

# To choose a different output device (ie a USB audio dongle or HDMI audio out),

# use `--device` with something like `--device hw:0,1`. Your mileage may vary.

#

#OPTIONS="--username <USERNAME> --password <PASSWORD>"

 

# Uncomment to use a cache for downloaded audio files. It's best to leave this

# as-is since permissions are properly set on directory `/var/cache/raspotify'.

#CACHE_ARGS="--cache /var/cache/raspotify"

 

OPTIONS="--device plughw:1 --initial-volume 100"

 

i gdzieś w tym pliku jest u Ciebie błąd dlatego nie ruchamia się raspotify.

 

Możesz wpisać też w konsoli to co niżej i ręcznie uruchomić może pokaże co jeszcze jest nie tak.

 

/usr/bin/librespot --name Raspotify --backend alsa --bitrate 320 --disable-audio-cache --device plughw:1 --initial-volume 100

 

Tom

 

Acha a póki co zrób:

 

sudo apt-get update

 

a potem:

 

sudo apt-get upgrade

 

może czegoś brakuje ale to było by dziwne.

 

Na czym instalujesz Raspotify jeśli Volumio to która wersja ?

 

Tom

Edytowane przez tomekwr123

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

tomekwr123

 

Serdecznie dziękuję za chęć dzielenia się wiedzą i cierpliwość.

 

Wszystko hula jak należy.

Problemem była zrobiona przez mnie literówka w linii komend.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tomaszu

 

Spotify widzi raspoti,łączy się przewija,można bez problemu wrócić do grania z telefonu...

Jednak cisza w głośnikach...

 

Myślę że na tym etapie dopiero coś zwaliłem:

:OPTIONS="--device plughw:1 --initial-volume 100"

 

U mnie w oknie Putty po "Option" było user i paswort

 

Dalsza pomoc niezbędna ale widać światełko w tunelu:-)

 

 

Mam Hiffibery dac pro

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tomaszu

 

Spotify widzi raspoti,łączy się przewija,można bez problemu wrócić do grania z telefonu...

Jednak cisza w głośnikach...

Myślę że na tym etapie dopiero coś zwaliłem:

:OPTIONS="--device plughw:1 --initial-volume 100"

U mnie w oknie Putty po "Option" było user i paswort

Dalsza pomoc niezbędna ale widać światełko w tunelu:-)

Mam Hiffibery dac pro

 

Podaj wynik polecenia:

 

aplay -l |grep card

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tomaszu

 

Wielkie dzięki już działa!!!

 

Jedna spacja za dużo.

Na informatyka to się nie nadaję:-)

 

Taka bezinteresowna pomoc przywraca wiarę w ludzi choć piwko się należy.Jak jesteś ze śląska lub okolic chciałbym postawić

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No niestety nie ze śląska, ale jak to mówią co się odwlecze to nie uciecze :-)

 

Ważne, że gra :-)

 

Myślę że w tym wątku zostało powiedziane wszystko co jest potrzebne żeby Spotify przywrócić do życia.

Ale oczywiście temat zostawiam otwarty :-)

Miejmy nadzieję, ze chłopaki szybko czegoś znowu nie popsują.

 

Pozdrawiam

Tomasz

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Czy wyłączenie aktualizacji Spotify może pomóc przed ponownymi problemami?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Czy wyłączenie aktualizacji Spotify może pomóc przed ponownymi problemami?

 

Ciężko stwierdzić, prawdopodobnie nie a wręcz może zaszkodzić.

Dlatego, że jak nie dokona się aktualizacja aplikacji Spotify to może być problem z połączeniem do serwerów z usługą Spotify.

Ale tego na sto procent nie wiem to tylko moje przypuszczenia.

Dlatego napisałem, że miejmy nadzieję, że chłopaki szybko czegoś nie popsują, miałem na myśli chłopaków od Spotify :-)

 

Tomek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Którą metodą ? rozumiem, że tą drugą.

Hej wczoraj pojawiła się aktualizacja aplikacji spotifi na win , niestety po aktualizacji również są problemy takie jak opisujecie w związku z sterowaniem przez tel. Na szczęście Twoje rozwiązanie rozwiązuje również ten problem . Świetna robota Tom , dzięki .

Pozdrawiam

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No i super, ważne że działa i oby jak najdłużej :-)

 

Tomek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dodam jeszcze jak ciekawostkę , mam drugi system na rpi 0w do tego justboom amp , używam z dedykowanym oprogramowaniem justboom + spotifi, który na moje oko różni się tylko kolorem od volumio ( jest czerwony ) .

Jednak jest różnica, wprawdzie tego urządzenia używam rzadko, ale od momentu instalacji jakieś 4 mc temu nic się z nim nie działo , nie było problemu z wtyczką spotifi , z aktualizacjami ( ich nie było wcale ) ich wersja systemu jest niezwykle stabilna .

Żałuje że justboom nie ma możliwości obsługi hata allo digione jaki mam w głównym systemie bo dawno bym zmienił .

Taka uwaga dla tych co przymierzają się do zestawu malina + jakiś hat niech rozważą nakładki od justboom nie są one tak popularne jak hifi berry ale myślę że dorównują im jakością i jest w czym wybierać , dodatkowo są tańsze .

Pozdrawiam

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Drogi Tomku

 

Ponownie mam problemy tym razem z raspotify które po twoich instrukcjach zainstalowałem.

Wygląda to następująco.

Widzi raspotify,łączy ale odtwarza z dużym opóźnienie.Po zmianie utworu ruszy lub nie choć czas leci.Po przejściu na fona gra od razu ponowne wybranie raspotify z reguły działa ale ze zmułą.

Restartowałem wszystko co związane z maliną(system,ruter...).

Jakiś pomysł będziesz miał na pewno

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

potestowałem i dodam:

Rusza zawsze tylko ze zwłoką nawet 45 sec a czas leci.

 

Pojawiła się nowa wtyczka na volumio i działa dokładnie jak raspotify.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Witam.

 

To trochę dziwne, bo u mnie tylko pierwsze łączenie z apki Spotify do raspotify trwa kilka sekund a potem już płynnie, no prawie pomiędzy utworami zdarzy się przerwa 2-3 sekundy ale to wszystko. Jako ciekawostkę napiszę, że dokładnie tak samo zachowuje się u mnie chromecast. Pierwsze łączenie dość długo nawet dłużej niż na malinie a potem w miarę płynnie.

Trzeba pamiętać, że raspotify nie obsługuje gapless, czyli płyty z koncertów nie będą się odtwarzać płynnie tylko zawsze po między trackami będzie przerwa, u mnie to jest jakieś 2 do 3 sekund. Nie wiem może ma to jakiś związek z szybkością internetu ? Nie bardzo wiem co może być nie tak bo u mnie aż taki problem nie występuje.

Postaram się bliżej temu przyjrzeć, może coś mi zaświta. Co do wtyczki w Volumio to obecnie jest prawdopodobnie zbudowana na tej samej bibliotece co raspotify.

Może potrzeba zaktualizować system poprzez sudo apt-get update i potem sudo apt-get upgrade, to nie powinno zaszkodzić.

 

Tom

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Brak gaples akceptuję.

Internet raczej ok jak puszczam Tidala przez buble działa,muza z Nas,radio(a tu ciekawostka sporo przestało działać)

Ja bym to porównał do długo używanego win 98 Na początku dobrze z czasem coraz gorzej.

Czyżby raspoti nazbierało jakiś śmieci?

 

Volumio mam najnowszą wersję choć to chyba nie ma znaczenia bo jak rozumiem to raspotify jest osobnym systemem?

 

Już oglądam alternatywne urządzenia tylko kto zagwarantuje że tam nie będzie takich problemów:-(

 

Jeszcze jedno Spotify connect Fon-PC dalej działa idealnie.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Czyżby raspoti nazbierało jakiś śmieci?

 

Volumio mam najnowszą wersję choć to chyba nie ma znaczenia bo jak rozumiem to raspotify jest osobnym systemem?

 

 

Generalnie Raspotify jest tylko aplikacją działającą pod linuxem a nie systemem.

Volumio to też szereg aplikacji działających pod linuxem.

Raspotify raczej nie zbiera śmieć, nawet celowo wyłączony ma bufor dla danych.

Poza tym tak jak wyżej napisałem ja takich problemów nie obserwuję u siebie. Problemem musi być coś innego tylko narazie nie mam jak tego sprawdzić bo u mnie tak na malinie jak i na chromecascie działa normalnie pomijając przerwy 2-3 sek. pomiędzy utworami.

 

Czy ktoś jeszcze ma podobny problem ?

 

Co do alternatyw to już tam odpowiedziałem :-) ale napiszę i tu, u mnie chromecasty pracują poprawnie jak narazie, czy to spotify czy Tidal czy Deezer ale oczywiście nikt nie da gwarancji, że jutro czy za rok będzie wszystko działać. Dlatego uważam, że malina jest ciekawą maszynką bo nawet jak coś przestanie działać to społeczność wcześniej czy później znajdzie rozwiązanie problemu, natomiast taki chromecast jest urządzeniem zamkniętym, jeżeli google porzuci projekt to nikt prawdopodobnie nic z tym nie zrobi, chociaż podobno jest możliwość odblokowania urządzenia i wrzucenia alternatywnego oprogramowania. Tego tematu jednak na razie nie próbowałem bo nie miałem potrzeby.

 

Tom

Edytowane przez tomekwr123

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Zrobiłem jedną czynność której nie zrobiłem dotychczas mianowicie wyłączyłem zasilanie Maliny(oczywiście najpierw zamknąłem system).

 

Pomogło i wszystko wróciło do normy.Samo resetowanie systemu było za słabe

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Nic nie zmieniałem w fonach.Telefony są na adroidzie.

Jedyna zmienna to była aktualizacja spotify.

 

Mam dwa telefony na jednym automatyczne aktualizacje na drugim nie.Po poprzednich jazdach najpierw sprawdzałem czy działa potem dopiero aktualizowałem ten którego używam częściej.Niestety teraz pominąłem ten krok

 

Poprzednio Tomaszu pomogło "twoje" Raspotify

niestety na nim jest połączenie ale nie ma dźwięku.

 

Z PC działa wyśmienicie jak zawsze.

 

Acha spotify na PC nie widzi volumio

 

Radpotify zresztą też

 

 

Po uśpieniu telefonu PC automatycznie też przestaje widzieć fona.

 

to samo przy zmianie aplikacji

 

Potestowałem ponownie stare wersje Spotify.

Problem jest identyczny czyli natychmiast rozłącza connect i ponownie nie można połączyć.

 

Jeśli nie Spotify jest winne to co?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Jeśli nie Spotify jest winne to co?

 

Zaczął bym od aktualizacji systemu z Volumio. Czyli logujemy się przez ssh na malinę i wydajemy komendy:

 

sudo apt-get update <enter> trzeba wpisać jeszcze raz hasło i <enter>

 

potem jak skończy:

 

sudo apt-get upgrade <enter> może zapytać czy uaktualnić wciskamy Y i chyba o ile nie zacznie aktualizacji <enter>

 

potem reboot i testujemy czy coś pomogło, niestety nie mam teraz dostępu do mojej maliny to za dużo sam nie sprawdzę :-( przynajmniej do następnego tygodnia.

 

W ten sposób powinno się udać zaktualizować nie tyle samo Volumio co biblioteki i np. Raspotify o ile był zainstalowany.

Druga możliwość jest taka, że chłopaki od Spotify znów coś popsuli i trzeba będzie poczekać na aktualizację apki w telefonie. I co gorsza to może być bliższe prawdy.

 

Tomek

Edytowane przez tomekwr123

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Na telefonie córki mam stare Spotify 1.2.5.3 i tam problem jest identyczny a żadnej aktualizacji nie robiłem.Ten sam problem.

 

Spróbuję twojego sposobu.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tomku

 

Zrobiłem jak radziłeś.

Nic nie pomogło.Za to znikło Raspotify.

 

Doinstaluję je ale nie przewiduje aby coś pomogło.

 

Zastanawiam się czy modem z kablówki może mieć jakiś wpływ choć wszystko inne działa normalnie nawet stream przez Bubleupnp

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Starą wtyczkę odinstalować w menu Volumio.

Poprzez SSH zainstalować nową wersję według recepty:

 

wget https://github.com/balbuze/volumio-plugins/raw/master/plugins/music_service/volspotconnect2/volspotconnect2.zip

 

mkdir ./volspotconnect2

 

miniunzip volspotconnect2.zip -d ./volspotconnect2

 

cd ./volspotconnect2

 

volumio plugin install

 

Tom

Edytowane przez tomekwr123

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Dzięki.

 

Mam jednak kłopoty z instalacją- po rozpakowaniu pliku ostatnie linie komend wyglądają tak:

 

volumio@volumio:~$ cd ./volspotconnect2

volumio@volumio:~/volspotconnect2$ volumio plugin install

 

This command will install the plugin on your device

 

No package found

volumio@volumio:~/volspotconnect2$

Edytowane przez jurek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

No package found

volumio@volumio:~/volspotconnect2$

 

U mnie wyglada to tak:

 

volumio@volumio:~$ cd ./volspotconnect2

volumio@volumio:~/volspotconnect2$ ls

SpotConnController.js node_modules uninstall.sh

UIConfig.json onstart1.sh volspotconnect2.jpg

config.json package.json volspotconnect2.service.tar

i18n readme.md volspotconnect2.tmpl

index.js remove.sh

install.sh startconnect.sh

volumio@volumio:~/volspotconnect2$ volumio plugin install

 

This command will install the plugin on your device

 

Compressing the plugin

Plugin succesfully compressed

Progress: 10

Status :Downloading plugin

Progress: 30

Status :Creating folder on disk

Progress: 40

Status :Unpacking plugin

Progress: 50

Status :Checking for duplicate plugin

Progress: 60

Status :Copying Plugin into location

Progress: 70

Status :Installing dependencies

Progress: 70

Status :Installing dependencies

Progress: 70

Status :Installing dependencies

Progress: 70

Status :Installing dependencies

Progress: 70

Status :Installing dependencies

Progress: 70

Status :Installing dependencies

Progress: 70

Status :Installing dependencies

Progress: 90

Status :Adding plugin to registry

Progress: 100

Status :Plugin Successfully Installed

Done!

volumio@volumio:~/volspotconnect2$

 

Działa, może jakaś literówka ?

 

Potem standardowo w menu Volumio trzeba włączyć wtyczkę ustawić initial volume i gra.

Metoda instaluje Volumio Spotify Connect2 dev ver 0.7.3

 

Całość robi się z poziomu użytkownika volumio, nie potrzeba korzystać z sudo.

 

Tom

Edytowane przez tomekwr123

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dołącz do dyskusji

Możesz dodać zawartość już teraz, a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.
Uwaga: Twój wpis zanim będzie widoczny, będzie wymagał zatwierdzenia moderatora.

Gość
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.


  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.