Jump to content
Holgin

DAC - PCM56, PCM61.

Recommended Posts

Zrobiłem pomiar w działającym odtwarzaczu z AD1860N. Clock to około 6.7MHz przy Fs 352.8 kHz. Poczytałem trochę i CLK/LE/DATA nie są synchroniczne w filtrach które grają z DACami tego typu. Przejrzałem trochę schematów i czasami na linii danych czy zegarów jest RC typu 200R/20pF, ale to nie pomogło. Jak będę mieć oscyloskop popatrzę na przebiegi i ich poziom, ale obawiam się, że może chodzić o dobór zegarów i nie da się tego prosto przerobić.

Share this post


Link to post
Share on other sites

Okej, udało się uruchomić AD1860N oraz AD1856N :) kolega .3lite jak zwykle wspomógł wiedzą, warto też czytać datasheety układów współpracujących no i serwisówki CDków, które pracują na DACach Analog Devices - wiele można podpatrzeć :)

Share this post


Link to post
Share on other sites

Ważny UPDATE - oba stabilizatory SMD maja być na 3V3. Zalutowanie wersji 5V może skończyć się uszkodzeniem AD1896!

BOM będzie niedługo poprawiany.

Zalecam też kupić układy 74AC161 zamiast 74HC161.

 

Share this post


Link to post
Share on other sites

Co prawda nikt tutaj nie wykazuje zainteresowania tym DACiem, ale o bezpieczeństwie warto zawsze wspomnieć:

Połączone AD811 i AD797 w pewnych konkretnych sytuacjach/aplikacjach potrafią się wzbudzić i usmażyć głośniki wysokotonowe. Nie mówię tutaj konkretnie o tym projekcie, mój osobisty egzemplarz gra odkąd projekt został opublikowany na tych WO, 100% oryginały i problemu nie ma, ale w przypadku innego projektu, z inną aplikacją analogu, opublikowanego na tym forum (PCM58), kilka razy tak się zdarzyło, że głośniki poszły z dymem :) Dlatego zalecam ostrożność.

Z moich doświadczeń wynika, że 4 warstwowe PCB pozytywnie wpływa na stabilność WO, a dobrze poprowadzone odsprzęganie oraz zastosowanie elementów SMD a nie THT w podstawkach (dodatkowe rezystancje/pojemności) też pomaga, ale mimo wszystko, wypada wspomnieć.

I myjcie płytki w izopropanolu :)

Share this post


Link to post
Share on other sites

Jakby ktoś potrzebował zdjęć w dużej rozdzielczości w celu sprawdzenia polaryzacji tantali to zapraszam. Na PCB dla obudów A i B niestety brakuje opisówki 🙂

Jeśli chodzi o sam projekt, słuchałem na PCM61, całość bardzo przyjemnie gra.

Na wyjściu PCM  jak i padach "SEL" (16/18bits) wlutowałem goldpiny z rastrem 2.54mm (lekko wygięte). Dzięki czemu można łatwo przepiąć jumperkiem tryb. 

 

88fa1adf8065b0082c4c59684971d90d_156589869901d732357473880881b3a88ab7d3a_1565898

 

Jedynie uwaga co do zasilacza i stabilizatora 7915 - niestety, ale bez obciążenia lubi podać na wyjściu zamiast -15VDC to -18 lub nawet -19VDC (przy napięciu wejściowym -28VDC). Dopiero po obciążeniu np LEDem napięcie spada do prawidłowej wartości). Także warto na to zwrócić uwagę jeśli ktoś by używał tego zasilacza z innym układem niż DAC na PCM.

 

Zdjęcie w dużej rozdzielczości:

https://www.flickr.com/photos/[email protected]/albums/72157710334241266

 

20190815_181718.jpg

Edited by gavron04

www.gavron04.diyaudio.pl układy audio

Share this post


Link to post
Share on other sites

Cieszę się, że ktoś składa, słucha i nawet się podoba 🙂 Dużo można w analogu zmienić, poprawić, eksperymenty są opisane trochę w wątku na sąsiednim forum.

13 godzin temu, gavron04 napisał:

Jedynie uwaga co do zasilacza i stabilizatora 7915 - niestety, ale bez obciążenia lubi podać na wyjściu zamiast -15VDC to -18 lub nawet -19VDC (przy napięciu wejściowym -28VDC). Dopiero po obciążeniu np LEDem napięcie spada do prawidłowej wartości). Także warto na to zwrócić uwagę jeśli ktoś by używał tego zasilacza z innym układem niż DAC na PCM.

To w sumie ciekawe - nigdy mi się nie przydarzyła taka historia ze stabilizatorami LM31X/LM78XX. Części jak rozumiem z kitu? Zawsze lutując taki zasilacz sprawdzam go na sucho i napięcia są takie jak powinny.

Co do opisówki - gdzieś w temacie powinien być zrzut z EAGLE gdzie polaryzacja jest zaznaczona, aczkolwiek i tak muszę się w końcu zebrać i poprawić bibliotekę, bo na oryginalnej z EAGLEa nie widać polaryzacji na PCB z fabryki. Mnie też to czasem irytuje 😉 

Share this post


Link to post
Share on other sites

317 337 kiedyś czytałem, żeby poprawnie działały trzeba je obciążyć np ledem.

Ale z 7915 pierwszy raz się spotkałem. Miałem drugi zasilacz gdzie nie było tego problemu, ale tam był stabilizator innego producenta. Na tym gdzie zauważyłem problem to były elementy zamówione z tme , oryginalne ST. Zamówiłem nowe sztuki, ale problem był ten sam. Jak trochę pogooglujesz to znajdziesz temat na diyaudio.com , że ten problem przy 7915 jest znany

Zasilacz złożony na elementach z kitu jest ok. Ten na którym był problem jest na https://www.tme.eu/pl/details/l7915acv/stabilizatory-napiecia-nieregulowane/st-microelectronics/ . Jak odkopiesz zamówienie na części to daj znać skąd zamawiałes 7915

Przeróbka biblioteki z tantalami to 5min 🙂 a aktualnie ryzyko, żeby ktoś popełnił błąd jest spore 🙂

Edited by gavron04

www.gavron04.diyaudio.pl układy audio

Share this post


Link to post
Share on other sites

Dobrze wiedzieć - nie znałem tego problemu z 7915, ale może też dlatego że mam fetysz LEDów i bardzo lubię mieć na PCB sygnalizację że zasilanie jest OK 🙂

 

Pogrzebie w rachunkach w wolnej chwili, nie wiem czy ujemne stabilizatory nie były brane z farnella.

Share this post


Link to post
Share on other sites
15 godzin temu, nick30 napisał:

Macie może jeszcze jedno PCB?

Mam kit z PCB do odsprzedania. Nawet kostki i potki się znajdą do kompletu. pisze tu, bo nie da się do ciebie wysłać PW


Seas L22+FW146+9950/FW146+WA30TW010/BG9/I-amp/China AK4490+Amanero/Nostromo3+RS headamp+Superlux HD681

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.