Jump to content
IGNORED

Trzaski z Fiio E10


Zares

Recommended Posts

Witam na forum.

 

Podczas słuchania przez FiiO E10 na Win7 słyszę trzaski.

 

Poszukałem trochę na forum i w sumie nic nie znalazłem. Może ktoś się również spotkał z podobnym problemem i wie, jak go rozwiązać?

 

No, ale żeby nie było - co zrobiłem?

  • wyłączyłem oszczędzanie energii w menedżerze urządzeń dla wszystkich głównych koncentratorów USB
  • w opcjach zasilania w panelu sterowania ustawiłem na wysoka wydajność
  • w w/w opcjach jest również możliwość wyłączenia wstrzymania selektywnego USB - ale to chyba działa tylko podczas, gdy urządzenie zostanie odłączone?
  • zwiększyłem bufor length w Foobarze2000 z 1000ms na 1990ms
  • próbowałem odtwarzać w Foobarze2000 poprzez KernelStreaming - niestety trzasków było chyba nawet więcej
  • próbowałem z innym kablem USB (od iRiver T30)

Zauważyłem również, że po kliknięciu w suwak od głośności (ten obok zegara na pasku), często zdarza się, że dźwięk po kliknięciu (ten "pynk") nie wydobywa się w całości, tylko jakby od połowy, jak gdyby z opóźnieniem. To samo przy dźwiękach z komunikatorów, np. dźwięk przychodzenia nowej wiadomości na Facebooku.

 

Tak więc nie jest to wina samego odtwarzacza (foobar2000), bo w innych programach (komunikatory), jak i samej przeglądarce (Chrome) problem również występuje.

 

Zasilacz nie no-name (Corsair CX600 V2), więc to chyba nie jest przyczyną trzasków? Co to w ogóle może być? Przerwy w działaniu, jakieś zakłócenia?

 

Byłbym ogromnie wdzięczny za pomoc, bo słuchanie muzyki, szczególnie tej spokojniejszej, z trzaskami nie jest komfortowe..

Link to comment
Share on other sites

Dzięki za odpowiedzi.

 

Na początku, jak go pierwszy raz podłączyłem, było 16/44 i były trzaski. Zmieniłem na 24/96 i żadnej poprawy.

 

Fading 100ms ustawiony od zawsze, po za tym problem występuje ogólnie, nie tylko w foobarze. Martwią mnie też te opóźnienia przy odtwarzaniu krótkich dźwięków, np dźwięk nadejścia wiadomości na Facebooku - to normalka u FiiO czy nie?

Link to comment
Share on other sites

Sprawdź czy masz coś podłączone pod inne porty. Najlepiej odłącz inne urządzenia. Mam Fiio e10 Olympus i przy podłączonym zewnętrznym dysku twardym słychać niemiłosierne trzaski. Również przy drugiej wersji e10 pojawiał się przester przy podłączonym line-out i słuchawkach jednocześnie.

Link to comment
Share on other sites

Adam, formata robić nie będę, bo to ostateczność, po za tym pozbycie się trzasków poprzez reinstalkę nie zastąpi mi straconego czasu na instalowanie na nowo programów. Nawet nie ma się pewności, że to pomoże.

 

Mavigo, pod inne porty, na tylnej obudowie oczywiście, mam podpięte:

  • myszkę
  • klawiaturę
  • drukarkę (wyłączona)
  • kamerkę (wyłączona)

Więc w sumie pozostają urządzenia, które podpięte być muszą (mysz, klawiatura), a reszta jest przecież wyłączona, jeśli urządzenie jest wyłączone/odłączone.

Nie są to też niemiłosierne trzaski, ale np. przy spokojnej muzyce je można dostrzec. Czasami po kilka naraz, więc jednak przeszkadza.

 

A co do odtwarzania krótkich dźwięków, np. dźwięk z Facebooka, to też tak masz, że jest często jest odtwarzany od połowy - nie słychać początku?

Link to comment
Share on other sites

Zares, jestem przekonany, a wiem to z mojego doświadczenia, że te wszystkie rządzenia USB, podłączone jednocześnie, mają wpływ na trzaski. Miałem podobny problem z Arcam rDAC podłączonym do kompa z Win7. Trzaski a raczej głośne strzały pojawiały się przy przełączaniu utworów, włączaniu i wyłączaniu. Prawdziwy koszmar. Oczywiście zmieniałem systemowe i programowe ustawienia o których piszesz ale bez zmian.

 

W efekcie rożnych prób zmontowałem sobie komputer tylko pod audio na bazie tej płyty

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Zaloguj się, aby zobaczyć treść (możliwe logowanie za pomocą ) z systemem linux -

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Zaloguj się, aby zobaczyć treść (możliwe logowanie za pomocą )

Komputer podpięty jest tylko do sieci Ethernet i zasilania - brak monitora, myszy i klawiatury. Do USB podpięty jest tylko DAC. Dostęp jest tylko zdalny.

 

Również zmieniłem w BIOSie przydzielone automatycznie przerwania (IRQ) ponieważ automatycznie na tym samym przerwaniu miałem kartę dźwiękowa i hub USB. Teraz USB jest na osobnym przerwaniu:

 

root@voyage:~# cat /proc/interrupts

CPU0

0: 18695598 XT-PIC-XT-PIC timer

1: 2 XT-PIC-XT-PIC i8042

2: 0 XT-PIC-XT-PIC cascade

9: 0 XT-PIC-XT-PIC acpi

10: 11883350 XT-PIC-XT-PIC eth0

11: 16337290 XT-PIC-XT-PIC ehci_hcd:usb1, ohci_hcd:usb2

12: 4 XT-PIC-XT-PIC i8042

14: 28849 XT-PIC-XT-PIC ide0

 

Efekt - żadnych trzasków.

Link to comment
Share on other sites

Przy dźwiękach systemowych - TAK, słychać od połowy, chyba za każdym razem. Poza tym, żadnych innych komplikacji. Wzmaka używam na laptopie, więc nie mam tylu urządzeń podłączonych. Lecz nawet przy zajętych wszystkich portach trzasków nie ma (myszka, modem usb, wzmak). Którą wersję E10 posiadasz? Spróbuj odłączyć wszystkie urządzenia z USB, poza Fiio, oraz sprawdź czy trzaski pojawiają się, kiedy dysk nie pracuje. Puść coś z pendriva na przykład. Może wtedy znajdziesz winowajcę.

Link to comment
Share on other sites

Jarekmor, piszesz, że przy przełączaniu, włączaniu i wyłączaniu - ja mam trzaski podczas odtwarzania muzyki, ale jeśli byś mógł, to proszę o instrukcje, jak te IRQ przypisać, by USB było osobno.

 

Mavigo, ale przecież mysz i klawiatura musi być podłączona, a reszta urządzeń jest wyłączona, no ale mogę je spróbować odłączyć, choć wątpię by to pomogło.

Wersja E10 - Olympus. Sprawdzę odtwarzanie z pendrive, ale przecież foobar i system działa na dysku, więc co za różnica? :)

 

Czytałem, że można zwiększyć jakoś buffor na USB, ale nie wiem, jak to zrobić - google mi wyświetla tylko zwiększenie bufforu klawiatury. Zwiększenie bufforu w Foobarze nic a nic nie dało, nawet do 13 000 ms.

 

Ściągnąłem również WASABI do Foobara, ale również zero poprawy.

Link to comment
Share on other sites

Zares,

W przypadku płyty Alix wyłączenie w BIOS wbudowanej karty dźwiękowej spowodowało, że USB nie dzieli tego samego przerwania.

Poza tym pod USB podpięte jest tylko jedno urządzenie - DAC USB. Brak myszy, klawiatury itp.

 

Spróbuj odłączyć wszystkie poza DACiem urządzania USB. Sprawdzimy czy będzie jakakolwiek zmiana.

Link to comment
Share on other sites

  • 7 months later...

Mam podobne objawy ale tylko z tym opóźnieniem dźwięku z Olympusem.

Trzasków brak a mam podpięte 8 urządzeń pod USB. Może coś z płytą główną? Najlepiej sprawdzić na innym komputerze.

 

Objawy opóźnienia dźwięku są takie jakby DAC coś tam sobie "ucinał" w muzyce i na początku.

Znalazłem fajny plik testowy, którym to sprawdzam ->

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Zaloguj się, aby zobaczyć treść (możliwe logowanie za pomocą )

 

W pewnym stopniu pomogła zmiana w ustawieniach DACa z 24 na 16 bit. Już nie ma wielkiego opóźnienia.

Ten DAC tak ma.

 

Więcej informacji użytkowników:

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Zaloguj się, aby zobaczyć treść (możliwe logowanie za pomocą )

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Zaloguj się, aby zobaczyć treść (możliwe logowanie za pomocą )

Link to comment
Share on other sites

ja mam trzaski podczas odtwarzania muzyki

Kolego, co prawda moja konfiguracja sprzetowa ( laptop i DAC ) jest zupełnie różna od Twojej ( też mam współdzielone przerwania, wspólną pamięc operacyjną i karty graficznej i pogardzanego przez wielu DAC'a) jednak sprawę opanowałem dawno temu. Chodziło głównie o to aby procek był minimum dwurdzeniowy ale kropkę nad i do pozbycia się pyknięć i trzasków postawiło wyłączenie na czas odtwarzania obu interfejsów sieciowych ( szczególnie wi-fi ). Od tej pory żadnych pyknięć i to nawet przy obciążaniu procka innym softem niż do odtwarzania muzyki.

 

P.S. Przez wyłączenie interfejsów sieciowych rozumiem czynność jaką robi się np. w menadżerze urządzeń wybierając dane urządzenie i klikając "wyłącz urządzenie"

 

Pozdr.

JacekPlacek

Link to comment
Share on other sites

Problem nie występuję tylko z Twoim DAC'iem jest to problem konfiguracji USB-DAC. Juz myślałem że jestem bardzo blisko rozwiązania problemu. Jednak jeszcze czasem występuję on u mnie. Ale badam to dalej.

 

Nic nie da zmaian bufora. Programu, czy tez Output w fobarze kernel Wasapi czy Asio.

Problem to konfikt przerwań (IRQ) sprawdz z jakim IRQ współdzieli Twoje USB. u mnie niestety wszystkie 3 podpięte są pod jedno. Dodatkowo mam tam mostek odpowiedzialny w pewnym sensie za kartę graficzną.

 

Możesz spróbować gasic urzadzenia które wspolniedzialą IRQ. pomału i delikatnie. Bo możesz wyłączyć za dużo.

Zwiększ także prorytet przerwania (danego numeru) w rejetrze windows. Każdo razowo jak uruchamiasz foobara zwiększaj jego priorytet na wysoki.

 

Daj znać czy coś pomogło. Jesli mam opisać dokładniej jak to zrobić daj znać.

Link to comment
Share on other sites

osobiście nie zauważyłem trzasków czy opóźnień na E10, dodatkowo coraz bardziej jestem z tego zakupu zadowolony gra przyjemnie może nie mega analitycznie ale nie męczy i nic nie próbuje na siłę udowadniać, bardzo muzykalnie i komfortowo z całkiem dobrą barwą i detalem,

 

co do trzasków to bardziej bym stawiał może na sam komputer i jego kontroler usb niż wskazywał od razu na E10.

Focal Elegia - xlr -> Naim Atom HE <- AQ Nrg Z3

Link to comment
Share on other sites

  • 2 months later...

kurcze u mnie też są trzaski na Win7 a na Linuxie nic nie ma. Dziwne, choć nie na wszystkich utworach. Mam Asusa Aspire 5733. Pożyczyłem taki sam laptop od kolegi i to samo. Ciekawe co za cholera tam siedzi. Nie bede taszczył drugiego kompa w delegacje, żeby posłuchać muzyki:)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

                  wykrzyknik.png

AdBlock blocking software detected!


Our website lives up to the displayed advertisements.
The ads are thematically related to the site and are not bothersome.

Please disable the AdBlock extension or blocking software while using the site.

 

Registered users can disable this message.