Jump to content
Ciechomir

Moode Audio Player dla Raspberry Pi i nie tylko

Recommended Posts

A u mnie podczas słuchania muzyki na najnowszym Moode, pojawia sie taki delikatny 'klik' w utworach. Zupełnie nie regularnie. Sprzęt to usbridge sign z prockiem Maliny. 

Ktoś z Was ma pomysł na eliminacje zjawiska? 

Share this post


Link to post
Share on other sites
W dniu 21.12.2019 o 14:55, sebaa1 napisał:

Temat przewagi wifi nad lan w malinie już został dawno udokumentowany pomiarami i wykresami. Tak kilka lat do tyłu w wątku
malinowymemoji6.png.

Kilka lat temu tak może i było. RPi4 ma w pełni sprawny gigabitowy lan.


Rega RP2+ // Pro-Ject DAC Box RS // Yamaha A-S1100 // KEF R700

Share this post


Link to post
Share on other sites

Nie, no nadal jest bardzo źle z wydajnością. Wymieniłem nawet raspberry 3 na 4. Po świeżej instalacji i podłączeniu zasobów z NAS interface nadal tnie się, muli. Czy 850GB muzyki w różnych formatch robi na moode aż takie wrażenie?

Wkurzyłem się i przesiadłem na Volumio. Tu wszystko po prostu pływa, działa tak jak powinno. NASa zaczytał raz dwa i śmiga płynnie. Dźwiękowo też jest tak jak powinno. Poza tym jest tu dużo więcej dodatków.

Mulenie moode to na pewno wina systemu a nie sprzętu. Na poprzednich wersjach zresztą było lepiej. 6.4 to padaka wydajnościowa.

Share this post


Link to post
Share on other sites
Kilka lat temu tak może i było. RPi4 ma w pełni sprawny gigabitowy lan.
Tu chodziło o to, że podłączony kabel LAN generował szum który zmierzono. Jak jest dzisiaj nie wiem bo jeszcze tego nikt nie zmierzył czy jest poprawa.

Share this post


Link to post
Share on other sites

W załączeniu plik z adresami url polskich stacji radiowych

Edytuj plik notepadem

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Zaloguj się, aby zobaczyć treść (możliwe logowanie za pomocą )


Haiku Audio Bright MK4 ; Audio Academy Hyperion IV Plus, Hegel HD25, Raspberry PI4 + Allo digione Signature, Cambridge Audio 752BD,

Share this post


Link to post
Share on other sites

Witam

Prośba o pomoc zakupiłem Raspberry 3B+ wgrałem Moode 6.4, poprzez kabel internetowy działa internet a po odłączeniu mój router nie widzi w ogóle moode po WIFI.

Przeglądałem jeden filmik na youtube  z Bootland dotyczy on Raspberry 3b bodajże uruchomienie WIFI lecz tam coś pokazują o osobnym module WIFI na USB.

Ja się doczytałem że 3B+ ma wbudowany moduł WIFI 2,5 oraz 5 GHZ ale tak jak wcześniej pisałem mój router nie widzi malinki po WIFI.

Czy faktycznie muszę użyć dodatkowego modułu WIFI pod USB?

Dodam że jako AP nie interesuje mnie podłączenie malinki, chcę tylko z telefonu na androidzie puszczać Spotify, Tidal i radio TuneIn poprzez  Malinkę po WIFI nie po kablu.

Acha i jak dograć Spotify? W apk Spotify zainstalowanej na telefonie wybierając urządzenie moode nie jest widoczny nawet po kablu, Tidal apk w Androidzie też nie jest widoczny moode ani BubleUpnp.

Za wszelkie porady z góry dziękuję i pozdrawiam.

jace699

Share this post


Link to post
Share on other sites
19 minut temu, jace699 napisał:

Ja się doczytałem że 3B+ ma wbudowany moduł WIFI 2,5 oraz 5 GHZ ale tak jak wcześniej pisałem mój router nie widzi malinki po WIFI.

A malina widzi router? Zdefiniowałes wifi w Moode?

Share this post


Link to post
Share on other sites
30 minut temu, jar1 napisał:

A malina widzi router? Zdefiniowałes wifi w Moode?

widzi mi już mój router ale wpisuje hasło z routera i po naciśnięciu SAVE i tak zapisuje mi się jakiś inny bardzo długi ciąg znaków?

kodowanie mam wpa2 i jak wyczyszcę ciąg znaków hasła i robię save to jest puste pole czyli dobrze a robiąc to samo po wpisamiu hasła dostępu do wifi z routera moje hasło zamienia sie w jakiś inny bardzo długi ciąg znaków i tak w kółko ten moode coś taki porabany jest bardzo.

Po przetłumaczeniu przez translator tam gdzie jest znak zapytania pokazuje takie coś:

Długość 8-63 znaków. Hasło zostanie przekonwertowane na klucz współdzielony (PSK) po zapisaniu.

Czyli mam rozumieć że hasło do mojego routera zostaje zmienione na jakiś inny format?

Ale czy mój router to odczyta?

Edited by jace699

Share this post


Link to post
Share on other sites

Nieprawidłowe hasło a jeszce nic nie zmieniałem od momentu instalacji moode 6.4.

Próbowałem w/g tego poradnika ale niestety hasło nie to:

Konfiguracja WiFi

Przez sieć łączymy się do RPi przez SSH. Nazwa użytkownika to pi, a hasło raspberry. Pod Windows możesz użyć programu PuTTY.

Pierwszym krokiem jest konfiguracja interejsu sieciowego WiFi. Po zalogowaniu się na RPi wydaj komendę:

sudo nano /etc/network/interfaces

Korzystanie z edytora nano. Jeżeli chcesz wyjść z edycji, nie zapisując wprowadzonych zmian, to naciśnij Ctrl+X i wybierz N. Wyjście i zapisanie zmian w pliku: Ctrl+X i wybór Y

Wygląd tego pliku nieco zmienia się z wersji na wersję, ale musisz się upewnić, że znajdzie się tam taki ciąg wpisów:

#auto wlan0

allow-hotplug wlan0

iface wlan0 inet manual

wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

 

iface default inet dhcp

Jeżeli są już jakieś wpisy dotyczace wlan0, usuń je (Ctrl+K usuwa całą linię w której jest kursor) i wpisz te powyżej. Definiują one interfejs sieciowy wlan0 do pracy z domyślnymi ustawieniami routerów WiFi.

Zwróć uwagę na znak # przed auto wlan0. Podana konfiguracja nieco różni się od takiej, jaką można spotkać w tutorialach dotyczących RPi. Nasza metoda (stan na maj 2015) w prosty sposób pozwala osiągnąć efekt automatycznego podłączania się do sieci WiFi. Nie tylko w momencie startu RPi, ale również w wypadku gdy sieć WiFi przez jakiś czas nie będzie dostępna (np z powodu restartu routera).

Wydaj komendę:

sudo nano /etc/rc.local

W tym pliku (na końcu) znajdziesz linię exit 0. Tuż nad tą linią, dodaj nową o następującej treści:

ifup wlan0

Kolejnym krokiem jest konfiguracja parametrów sieci WiFi takich jak jej nazwa, hasło i sposób szyfrowania.

sudo nano /etc/wp_supplicant/wpa_supplicant.conf

Zapewne będzie tam kilka linii, ale nie będzie zdefiniowanej żadnej sieci. Dodaj wpis network={}, a między nawiasami podaj wszystkie parametry sieci. Każdy jest w oddzielnej linii.

network={

ssid="SSID"

psk="HASŁO"

    }

Oczywiście SSID i HASŁO muszą być odpowiednie dla Twojej sieci. Pozostałe paramatery RPi spróbuje dobrać automatycznie.

Po restarcie urządzenia (komenda sudo reboot) i odczekaniu pewnego czasu RPi powinno być dostępne w sieci WiFi.

Edited by jace699

Share this post


Link to post
Share on other sites

Panowie poradziłem sobie z konfiguracją wszystkiego, Lan i Wifi też działa, Spotify chodzi, Tidal też chodzi, Malinkę mam na razie podłączoną próbnie poprzez kabel jack z głośniczkiem i wszystko pięknie chodzi ale mam pytanko?

Zamierzam zakupić wzmacniacz Marantz model 7005 z wbudowanym wejściem USB "B" , mam do tego już zakupiony kabel USB A na USB B i w czwartek idę wypróbować Malinkę na odsłuch tego Marantza do sklepu HIFI i teraz mam bardzo ważne pytanie:

Wklejam teraz instrukcję z instalacji Moode oraz konfiguracji wyjścia USB  - Audio.

Ja mam ustawione tak: w Devices /  I2S audio device na None, w MPD Edit / MPD Config / Audio device / Device type na Device type On-board audio device

nie mam ustawionej tej opcji: Set Device type to "USB audio device" then SAVE - I2S DEVICE

Tylko dodam że tej opcji nie ma, szukałem w moode 6.4 i nie znalazłem.

Moje pytanie brzmi czy na pewno mam ustawione strikte na wyjście audio po przewodzie USB do Marantza i to mi zadziała?

2. AUDIO DEVICE SETUP

- USB DEVICE

a) Menu, Configure, Audio

b) Select "None" for I2S audio device then SET

c) Reboot

d) Menu, Configure, Audio

e) MPD options: EDIT OPTIONS

f) Leave Volume control set to "Software"

g) Set Device type to "USB audio device" then SAVE

- I2S DEVICE

Pozdrawiam

jace699

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.